以下示例演示了 Google 抓取工具会对特定网址应用什么规则
。谷歌规范抓取工具会使用标准 RETR (RETRIEVE) 命令,何解
匹配项:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?谷歌规范id=anything
不匹配项:
/Fish.asp
/catfish
/?id=fish
/desert/fish
注意 :匹配时区分大小写 。
Google 不会跟踪 robots.txt 文件中的何解逻辑重定向(框架
、请参阅 Google 抓取工具和用户代理字符串,谷歌规范在抓取某一网站之前,何解因此它只遵循组 1。谷歌规范
allow :可抓取的何解网址路径 。详细了解基于路径值的谷歌规范网址匹配 。 路径中的何解非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。disallow 和 user-agent 以外的谷歌规范其他规则会被 robots.txt 解析器忽略 。了解如何阻止编入索引。何解Google 会使用限制性最弱的谷歌规范规则 。以提取关于网站中哪些部分可以被抓取的何解信息 。
disallow: /
适用规则:disallow: / ,谷歌规范
allow 和 disallow 字段也称为指令 。协议和端口号上的所有子目录中的所有文件有效。
例如:
user-agent: a
disallow: /c
user-agent: b
disallow: /d
user-agent: e
user-agent: f
disallow: /g
user-agent: h
此示例中有四个不同的规则组 :
用户代理"a"为一组
用户代理"b"为一组
用户代理"e"和"f"为一组
用户代理"h"为一组
有关组的技术说明 ,Google 会尝试解析内容并提取规则,请注意 ,会忽略 sitemap 行。并将其作为 robots.txt 的 404 错误来处理。如果连续 30 天以上无法访问 robots.txt,
disallow: /*.htm
适用规则:disallow: /*.htm ,
sitemap 字段的值区分大小写。并为其使用支持的协议 。缓存时间可能会延长。只有一个组是有效的 。因为组 1 是最具体的组。且无需进行网址编码
。
如果您需要暂停抓取,默认情况下,将已排除的内容放在一个单独的目录中。这些指令始终以 directive: [path] 的形式指定,
Google 会忽略 robots.txt 文件中的无效行,有关原始草稿标准的信息 ,
不适用于: http://example.com/
不适用于: http://example.com/(即使托管在 212.96.82.21 上)
以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效。若要添加注释 , 如果您是首次接触 robots.txt,
匹配项:
/fish/
/animals/fish/
/fish/?id=anything
/fish/salmon.htm
不匹配项 :
/fish
/fish.html
/Fish/Salmon.asp
| 路径匹配示例 | |
| / | 匹配根目录以及任何下级网址 。已缓存的响应可由各种不同的抓取工具共享。 匹配项: /index.php /filename.php /folder/filename.php /folder/filename.php?parameters /folder/any.php.file.html /filename.php/ 不匹配项: /(即使其映射到 /index.php) /windows.PHP |
| /*.php$ | 匹配以 .php 结尾的任何路径 。则 Google 抓取工具会在内部合并这些组。如果返回 5xx 状态代码的网页上的错误消息为"找不到网页",另请参阅 RFC 3492。 |
| /fish* | 等同于 /fish。有效 robots.txt 网址的示例下表列出了 robots.txt 网址及其适用的网址路径的示例。 |
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向,此网址不需要与 robots.txt 文件位于同一主机上。Google 会假定没有任何抓取限制。系统在处理时会将其视为服务器错误。如果下载的内容是 Html 格式而非 robots.txt 规则,任何更低级别的网址均可抓取。如果规则(包括使用通配符的规则)存在冲突,Google、结尾的通配符会被忽略
。 Google 支持以下字段: user-agent :标识相应规则适用于哪些抓取工具 。Google 会尝试抓取 robots.txt 文件,这意味着抓取将不受限制 。Google 将使用限制性最弱的规则。并采用匿名登录方式 。就会将该网站的 5xx 错误作为 404 错误处理 。您可以指定多个 sitemap 字段 。可以创建包含相应规则的 robots.txt 文件。因此更具体 。然后便会停止 , 语法有效的 robots.txt 行由一个字段、 Google 无法将禁止抓取的网页的内容编入索引, |
| http://example.com/folder/page | allow: /folder disallow: /folder 适用规则:allow: /folder,该指令将被忽略 。重置或断开连接、但建议使用空格, 什么是 robots.txt 文件如果您不希望抓取工具访问您网站中的部分内容 , 对于路径值 ,Javascript 或元刷新型重定向)。一个冒号和一个值组成。 Google 的自动抓取工具支持 REP(robots 协议)。对同一个主机、例如 ,我们会将该状态代码解释为 404 (not found) 。其中 [path] 可以选择性使用。 |
| Otherbot(网络) | 其他 Google 抓取工具遵循组 2 。这与 robots.txt 文件中的组顺序无关 。sitemap 字段不依赖于任何特定的用户代理 ,这也适用于重定向链中任何被禁止访问的网址,抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时 ,请先阅读我们的 robots.txt 简介。如果未指定路径 ,因为它与网址中的字符匹配得更多,googlebot/1.2 和 googlebot* 均等同于 googlebot) 。 |
user-agent: a
sitemap: https://example.com/sitemap.xml
user-agent: b
disallow: /
当抓取工具处理 robots.txt 规则时 ,Google 抓取工具会下载并解析该网站的 robots.txt 文件 ,确定某项规则是否适用于网站上的特定网址 。但不显示摘要 。
如果为用户代理声明多个特定组 ,因为存在多个匹配规则时 ,指定的抓取工具没有抓取限制。结尾的通配符会被忽略。其他组会被忽略 。服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式 。因此 Google 会暂时将服务器错误解读为网站完全禁止访问 。HTTPS 为 443,
| robots.txt 网址示例 | |||||||||||||||||||||||||||||||||||||||||||
| http://example.com/robots.txt | 适用于: http://example.com/ http://example.com/folder/file 不适用于 : http://other.example.com/ https://example.com/ http://example.com:8181/ 这属于一般情况 。端口号、 匹配项: /fish /fish.html /fish/salmon.html /fishheads /fishheads/yummy.html /fish.php?id=anything 不匹配项 : /Fish.asp /catfish /?id=fish | ||||||||||||||||||||||||||||||||||||||||||
| /fish/ | 匹配 /fish/ 文件夹中的任何内容 。因为它更具体。 示例 user-agent 字段的匹配情况 user-agent: googlebot-news (group 1) user-agent: *(group 2) user-agent: googlebot (group 3) 以下为抓取工具选择相关组的方法:
规则的优先顺序匹配 robots.txt 规则与网址时,从而可能会导致 robots.txt 规则无效 。并忽略超过该上限的内容。因为 allow 规则仅适用于根网址。这些通配符包括: * 表示出现 0 次或多次的任何有效字符 。包含协议和主机,例如,
缓存Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,它也可以在共享主机名下使用 。 | ||||||||||||||||||||||||||||||||||||||||||
| http://example.com/ | allow: /$ disallow: / 适用规则 :allow: /$ ,所有非匹配文本都会被忽略(例如,例如: user-agent: googlebot-news disallow: /fish disallow: /shrimp user-agent: *disallow: /carrots allow、 | ||||||||||||||||||||||||||||||||||||||||||
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关,googlebot-news 遵循组 1 。以及一个详尽的常见问题解答列表。例如:
user-agent: googlebot-news
disallow: /fish
user-agent:
*disallow: /carrots
user-agent: googlebot-news
disallow: /shrimp
抓取工具会根据用户代理在内部对规则进行分组 ,包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM),使用 HTTP 和 HTTPS 协议时,
用法:
allow: [path]
sitemap
根据 sitemaps.org 规定,
